Beranda > @GNS3 Lab, bsci > Lab BSCI: Implementasi dan Verifikasi EIGRP

Lab BSCI: Implementasi dan Verifikasi EIGRP

1-topology-eigrp1

Konfigurasi

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router eigrp 1
R2(config-router)#network 10.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#^Z
R2#
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router eigrp 1
R3(config-router)# network 10.0.0.0
R3(config-router)# no auto-summary
R3(config-router)#^Z
R3#

Verifikasi

Untuk memverifikasi apakah protokol EIGRP sudah aktif bisa menggunakan perintah sh ip prot

R3#sh ip prot
Routing Protocol is “eigrp 1”
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.2.2              90      00:00:34
  Distance: internal 90 external 170

Dan untuk melihat neighbor adjacency bisa dilakukan dengan mengeksekusi sh ip eigrp neighbor

R3#sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.2.2                Et1/0             13 00:03:45   71   426  0  7

Dan untuk melihat tabel routing bisa dengan mengeksekusi perintah sh ip route

R3#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.1.2.0/24 is directly connected, Ethernet1/0
D       10.1.24.0/30 [90/2195456] via 10.1.2.2, 00:05:05, Ethernet1/0
C       10.1.34.0/30 is directly connected, Serial0/0

Sekarang pada router BackBone (BB), kita akan menggunakan wildcard mask dalam konfigurasi EIGRP

BB#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
BB(config)#router eigrp 1
BB(config-router)#network 10.1.34.0 0.0.0.255
BB(config-router)#
*Mar  1 00:34:47.295: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.34.1 (Serial0/0) is up: new adjacency
BB(config-router)#no auto-summary
BB(config-router)#
*Mar  1 00:35:34.015: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.34.1 (Serial0/0) is resync: summary configured
BB(config-router)#network 172.30.0.0 0.0.255.255
BB(config-router)#network 10.1.24.2 0.0.0.0
BB(config-router)#
*Mar  1 00:40:27.419: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.24.1 (Serial0/1) is up: new adjacency
BB(config-router)#^Z
BB#

Dan seperti biasa kita verifikasi keaktifan EIGRP

BB#sh ip prot
Routing Protocol is “eigrp 1”
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.1.24.2/32
    10.1.34.0/24
    172.30.0.0s
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.24.1             90      00:01:52
    10.1.34.1             90      00:01:52
  Distance: internal 90 external 170

Kita lihat diatas 10.1.24.1 dan 10.1.34.1 adalah neighbor dari router BB, cara paling mudah untuk mengetahui neighbor suatu router adalah dengan sh ip eighr nei

BB#sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                                             (sec)         (ms)       Cnt Num
1   10.1.24.1               Se0/1             13 00:04:01   92   552  0  11
  10.1.34.1               Se0/0             14 00:09:41  113   678  0  10

Perintah berikut yang akan kita pelajari adalah sh ip eigrp topology, perintah ini digunakan untuk menampilkan tabel topology router EIGRP

BB#sh ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(172.30.7.1)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
       r – reply Status, s – sia Status

P 10.1.2.0/24, 2 successors, FD is 2195456
        via 10.1.24.1 (2195456/281600), Serial0/1
        via 10.1.34.1 (2195456/281600), Serial0/0
P 10.1.24.0/30, 1 successors, FD is 2169856
        via Connected, Serial0/1
P 10.1.34.0/30, 1 successors, FD is 2169856
        via Connected, Serial0/0
P 172.30.2.0/24, 1 successors, FD is 128256
        via Connected, Loopback2
P 172.30.3.0/24, 1 successors, FD is 128256
        via Connected, Loopback3
P 172.30.0.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 172.30.1.0/24, 1 successors, FD is 128256
        via Connected, Loopback1
P 172.30.6.0/24, 1 successors, FD is 128256
        via Connected, Loopback6
P 172.30.7.0/24, 1 successors, FD is 128256
        via Connected, Loopback7
P 172.30.4.0/24, 1 successors, FD is 128256
        via Connected, Loopback4
P 172.30.5.0/24, 1 successors, FD is 128256
        via Connected, Loopback5

Perhatikan output diatas, terdapat 2 successor untuk network destination 10.1.2.0/24, yang kedua-duanya memiliki metric yang equal, kedua successor (karena equal) akan dimasukkan kedalam tabel routing semua

BB#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     172.30.0.0/24 is subnetted, 8 subnets
C       172.30.2.0 is directly connected, Loopback2
C       172.30.3.0 is directly connected, Loopback3
C       172.30.0.0 is directly connected, Loopback0
C       172.30.1.0 is directly connected, Loopback1
C       172.30.6.0 is directly connected, Loopback6
C       172.30.7.0 is directly connected, Loopback7
C       172.30.4.0 is directly connected, Loopback4
C       172.30.5.0 is directly connected, Loopback5
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.1.2.0/24 [90/2195456] via 10.1.34.1, 00:55:56, Serial0/0
                    [90/2195456] via 10.1.24.1, 00:55:56, Serial0/1
C       10.1.24.0/30 is directly connected, Serial0/1
C       10.1.34.0/30 is directly connected, Serial0/0

Sekarang bagaimana jika kedua metric route diatas tidak equal, kita dapat mengubah bandwidth salah satu link untuk membuat keduanya menjadi unequal

BB#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
BB(config)#int s0/0
BB(config-if)#bandwidth 1000
BB(config-if)#^Z
BB#
Sekarang perhatikan tabel routing berikut
BB#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     172.30.0.0/24 is subnetted, 8 subnets
C       172.30.2.0 is directly connected, Loopback2
C       172.30.3.0 is directly connected, Loopback3
C       172.30.0.0 is directly connected, Loopback0
C       172.30.1.0 is directly connected, Loopback1
C       172.30.6.0 is directly connected, Loopback6
C       172.30.7.0 is directly connected, Loopback7
C       172.30.4.0 is directly connected, Loopback4
C       172.30.5.0 is directly connected, Loopback5
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.1.2.0/24 [90/2195456] via 10.1.24.1, 00:01:52, Serial0/1
C       10.1.24.0/30 is directly connected, Serial0/1
C       10.1.34.0/30 is directly connected, Serial0/0

Entri route untuk network destination 10.1.2.0/24 kini tinggal satu saja, tetapi, informasi route tersebut masih tersimpan dalam tabel topologi

BB#sh ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(172.30.7.1)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
       r – reply Status, s – sia Status

P 10.1.2.0/24, 1 successors, FD is 2195456
        via 10.1.24.1 (2195456/281600), Serial0/1
        via 10.1.34.1 (3097600/281600), Serial0/0
P 10.1.24.0/30, 1 successors, FD is 2169856
        via Connected, Serial0/1
P 10.1.34.0/30, 1 successors, FD is 3072000
        via Connected, Serial0/0
        via 10.1.24.1 (2707456/2195456), Serial0/1
P 172.30.2.0/24, 1 successors, FD is 128256
        via Connected, Loopback2
P 172.30.3.0/24, 1 successors, FD is 128256
        via Connected, Loopback3
P 172.30.0.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 172.30.1.0/24, 1 successors, FD is 128256
        via Connected, Loopback1
P 172.30.6.0/24, 1 successors, FD is 128256
        via Connected, Loopback6
P 172.30.7.0/24, 1 successors, FD is 128256
        via Connected, Loopback7
P 172.30.4.0/24, 1 successors, FD is 128256
        via Connected, Loopback4
P 172.30.5.0/24, 1 successors, FD is 128256
        via Connected, Loopback5

inilah fitur EIGRP yang tidak dimiliki oleh protokol routing lain, EIGRP menyimpan route backup sebagai cadangan jika terjadi failure pada jalur utama.

Default gateway

Misalkan router backbone adalah default gateway bagi router yang lain untuk mengakses ke internet,  router ini terhubung dengan ISP dengan address 170.30.0.2. EIGRP mempunyai beberapa cara untuk mendistribusikan default gateway pada semua router. Salah satunya seperti berikut

BB#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
BB(config)#ip default-network 172.30.0.0
BB(config)#^Z
BB#

Hal ini akan menandai salah satu entri sebagai default route, tetapi hal ini tidak berpengarh apa-apa pada router BB, seperti kita lihat, status dari gateway tetap “Gateway of last resort is not set”

BB#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

 *   172.30.0.0/24 is subnetted, 8 subnets
C       172.30.2.0 is directly connected, Loopback2
C       172.30.3.0 is directly connected, Loopback3
C*      172.30.0.0 is directly connected, Loopback0
C       172.30.1.0 is directly connected, Loopback1
C       172.30.6.0 is directly connected, Loopback6
C       172.30.7.0 is directly connected, Loopback7
C       172.30.4.0 is directly connected, Loopback4
C       172.30.5.0 is directly connected, Loopback5
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.1.2.0/24 [90/2195456] via 10.1.24.1, 00:07:09, Serial0/1
C       10.1.24.0/30 is directly connected, Serial0/1
C       10.1.34.0/30 is directly connected, Serial0/0

Tetapi kita lihat apa yang terjadi pada router lainnya.

R2#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is 10.1.24.2 to network 172.30.0.0

     172.30.0.0/24 is subnetted, 8 subnets
D       172.30.2.0 [90/2297856] via 10.1.24.2, 00:13:16, Serial0/0
D       172.30.3.0 [90/2297856] via 10.1.24.2, 00:13:16, Serial0/0
D*      172.30.0.0 [90/2297856] via 10.1.24.2, 00:06:11, Serial0/0
D       172.30.1.0 [90/2297856] via 10.1.24.2, 00:13:16, Serial0/0
D       172.30.6.0 [90/2297856] via 10.1.24.2, 00:13:16, Serial0/0
D       172.30.7.0 [90/2297856] via 10.1.24.2, 00:13:16, Serial0/0
D       172.30.4.0 [90/2297856] via 10.1.24.2, 00:13:16, Serial0/0
D       172.30.5.0 [90/2297856] via 10.1.24.2, 00:13:16, Serial0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.1.2.0/24 is directly connected, Ethernet1/0
C       10.1.24.0/30 is directly connected, Serial0/0
D       10.1.34.0/30 [90/2195456] via 10.1.2.1, 00:13:18, Ethernet1/0
R2#

Walaupun router BB belum memiliki default gateway, tetapi router lain telah mengacu pada router BB sebagai default gateway..

Berikut cara lain untuk mendistribusikan default gateway

BB#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
BB(config)#ip route 0.0.0.0 0.0.0.0 lo 0
BB(config)#router eigrp 1
BB(config-router)#network 0.0.0.0
BB(config-router)#^Z
BB#

Kita lihat sekarang pada tabel routing, router BB sudah memiliki default gateway

BB#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.30.0.0/24 is subnetted, 8 subnets
C       172.30.2.0 is directly connected, Loopback2
C       172.30.3.0 is directly connected, Loopback3
C       172.30.0.0 is directly connected, Loopback0
C       172.30.1.0 is directly connected, Loopback1
C       172.30.6.0 is directly connected, Loopback6
C       172.30.7.0 is directly connected, Loopback7
C       172.30.4.0 is directly connected, Loopback4
C       172.30.5.0 is directly connected, Loopback5
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.1.2.0/24 [90/2195456] via 10.1.24.1, 00:18:25, Serial0/1
C       10.1.24.0/30 is directly connected, Serial0/1
C       10.1.34.0/30 is directly connected, Serial0/0
S*   0.0.0.0/0 is directly connected, Loopback0

Dan kita lihat pada tabel routing router lain, seharusnya default gateway ini sudah terdistribusikan

R2#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is 10.1.24.2 to network 0.0.0.0

     172.30.0.0/24 is subnetted, 8 subnets
D       172.30.2.0 [90/2297856] via 10.1.24.2, 00:19:55, Serial0/0
D       172.30.3.0 [90/2297856] via 10.1.24.2, 00:19:55, Serial0/0
D       172.30.0.0 [90/2297856] via 10.1.24.2, 00:03:21, Serial0/0
D       172.30.1.0 [90/2297856] via 10.1.24.2, 00:19:55, Serial0/0
D       172.30.6.0 [90/2297856] via 10.1.24.2, 00:19:55, Serial0/0
D       172.30.7.0 [90/2297856] via 10.1.24.2, 00:19:55, Serial0/0
D       172.30.4.0 [90/2297856] via 10.1.24.2, 00:19:55, Serial0/0
D       172.30.5.0 [90/2297856] via 10.1.24.2, 00:19:55, Serial0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.1.2.0/24 is directly connected, Ethernet1/0
C       10.1.24.0/30 is directly connected, Serial0/0
D       10.1.34.0/30 [90/2195456] via 10.1.2.1, 00:19:56, Ethernet1/0
D*   0.0.0.0/0 [90/2297856] via 10.1.24.2, 00:02:44, Serial0/0
Kategori:@GNS3 Lab, bsci
  1. foreverma
    April 22, 2009 pukul 10:34 am

    weh! berat nih bahasan, hehe. Aku aja lom bljr sampe situ. mantap2! ayo lanjutkan! jgn lupa rajin2 berkunjung d blog aku ya.

  1. No trackbacks yet.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: