Beranda > @GNS3 Lab, ccna > GNS3 Lab ICND2: Konfigurasi RIP

GNS3 Lab ICND2: Konfigurasi RIP

Untuk informasi, semua IP address yang dipakai pada lab ini adalah private IP address, yang berarti lab ini tidak bisa melakukan koneksi ke Internet, kecuali satu interface milik R1 yakni e0/1 yang akan diberikan IP address publik untuk nanti digunakan dalam konfigurasi lab NAT.

icnd2_topology25

Konfigurasi RIP

Pada R1 Kita akan mengaktifkan RIP pada interface e0/0 saja, dan tidak pada interface yang telah di assign IP publik agar RIP tidak meng-advertise prefix network IP Private ke Internet

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 192.168.1.0
R1(config-router)#^Z
R1#

Untuk melihat apakah proses RIP telah berjalan dapat dilihat dengan perintah sh ip proto

R1#sh ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 8 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive version 2
Interface             Send  Recv  Triggered RIP  Key-chain
Ethernet0/0           2     2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
192.168.1.0
Routing Information Sources:
Gateway         Distance      Last Update
Distance: (default is 120)

Kini kita konfigurasi R2

R2#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.2     YES NVRAM  up                    up
FastEthernet0/0.10         192.168.10.1    YES NVRAM  up                    up
FastEthernet0/0.20         192.168.20.1    YES NVRAM  up                    up
Serial1/0                  192.168.2.1     YES NVRAM  up                    up

Dapat kita lihat bahwa R2 terhubung pada 4 network (VLAN) yakni 192.168.1.0/24, 192.168.2.0/24, 192.168.10.0/24 dan 192.168.20.0/24, kita akan mengaktifkan RIP untuk semua network tersebut

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.10.0
R2(config-router)#network 192.168.20.0
R2(config-router)#network 192.168.2.0
R2(config-router)#^Z
R2#

Kita tahu bahwa R1 tidak terhubung pada VLAN10 (192.168.10.0/24) dan VLAN20 (192.168.20.0/24) serta network 192.168.2.0/24, tetapi karena R1 dan R2 telah diaktifkan protokol RIP, keduanya akan bertukar informasi tabel routing, dan kini router R1 telah mendapatkan informasi network network yang terhubung pada R2 melalui RIP

R1#sh ip route
Gateway of last resort is not set
R    192.168.10.0/24 [120/1] via 192.168.1.2, 00:00:08, Ethernet0/0
R    192.168.20.0/24 [120/1] via 192.168.1.2, 00:00:08, Ethernet0/0
C    192.168.1.0/24 is directly connected, Ethernet0/0
R    192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:08, Ethernet0/0

Kini saatnya untuk mengkonfigurasi R3

R3#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  192.168.2.2     YES NVRAM  up                    up
Ethernet1/0                192.168.3.1     YES NVRAM  up                    up

Kita tahu R3 terhubung pada network 192.168.2.0/24 dan 192.168.3.0/24, berikut konfigurasi RIP-nya

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router rip
R3(config-router)#network 192.168.2.0
R3(config-router)#network 192.168.3.0
R3(config-router)#^Z
R3#

Testing Koneksi

Kini semua network telah terhubung dan dapat berkomunikasi satu sama lain

root@teddy:~# ping 192.168.20.20
PING 192.168.20.20 (192.168.20.20) 56(84) bytes of data.
64 bytes from 192.168.20.20: icmp_seq=1 ttl=64 time=2.19 ms
^C
— 192.168.20.20 ping statistics —
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 2.194/2.194/2.194/0.000 ms
root@teddy:~# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=254 time=43.8 ms
64 bytes from 192.168.1.1: icmp_seq=1 ttl=254 time=102 ms (DUP!)
64 bytes from 192.168.1.1: icmp_seq=2 ttl=254 time=33.3 ms
^C
— 192.168.1.1 ping statistics —
2 packets transmitted, 2 received, +1 duplicates, 0% packet loss, time 1006ms
rtt min/avg/max/mdev = 33.371/59.885/102.421/30.380 ms
root@teddy:~# ping 192.168.2.1
PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
64 bytes from 192.168.2.1: icmp_seq=1 ttl=255 time=26.2 ms
^C
— 192.168.2.1 ping statistics —
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 26.260/26.260/26.260/0.000 ms
root@teddy:~# ping 192.168.2.2
PING 192.168.2.2 (192.168.2.2) 56(84) bytes of data.
64 bytes from 192.168.2.2: icmp_seq=1 ttl=254 time=69.0 ms
^C
— 192.168.2.2 ping statistics —
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 69.066/69.066/69.066/0.000 ms
root@teddy:~#

Default Gateway/Route

Router R1 adalah satu-satunya router yang terhubung ke Publik Address Internet, Router inilah yang akan digunakan oleh seluruh network sebagai default gateway untuk melakukan koneksi ke internet (dengan NAT yang akan dibahas pada postingan mendatang). Untuk sekarang kita akan mengkonfigurasi R1 agar default gateway nya mengarah pada ISP (provider yang menyediakan koneksi ke internet).

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ip route 0.0.0.0 0.0.0.0 168.205.34.97
R1(config)#^Z
R1#

Dengan begini R1 telah memiliki default gateway yang menunjuk pada ISP (168.205.34.97) dan dengan begitu bisa melakukan koneksi ke internet, kita bisa melihatnya pada tabel routing

R1#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route
Gateway of last resort is 168.205.34.97 to network 0.0.0.0
168.205.0.0/27 is subnetted, 1 subnets
C       168.205.34.96 is directly connected, Ethernet0/1
R    192.168.10.0/24 [120/1] via 192.168.1.2, 00:00:04, Ethernet0/0
R    192.168.20.0/24 [120/1] via 192.168.1.2, 00:00:04, Ethernet0/0
C    192.168.1.0/24 is directly connected, Ethernet0/0
R    192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:04, Ethernet0/0
S*   0.0.0.0/0 [1/0] via 168.205.34.97

Sedangkan seluruh network lainnya masih belum bisa melakukan koneksi ke internet karena 2 hal,

  • Belum memiliki default gateway
  • Konfigurasi NAT belum dijalankan

Untuk konfigurasi default gateway, kita bisa mendistribusikan routing statik yang dimiliki oleh R1 kedalam proses RIP, sehingga semua router-router lainnya menerima informasi default gateway, berikut konfigurasinya

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router rip
R1(config-router)#redistribute static
R1(config-router)#^Z
R1#

Kita bisa melihat hasil konfigurasi diatas pada router lainnya, hasilnya seperti berikut

R2#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route
Gateway of last resort is 192.168.1.1 to network 0.0.0.0
C    192.168.10.0/24 is directly connected, FastEthernet0/0.10
C    192.168.20.0/24 is directly connected, FastEthernet0/0.20
C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    192.168.2.0/24 is directly connected, Serial1/0
R*   0.0.0.0/0 [120/1] via 192.168.1.1, 00:00:08, FastEthernet0/0

Kita lihat pada tabel routing R2 memiliki default gateway yang didapatkan dari RIP. Begitu juga R3 juga akan mendapatkan advertise default gateway dari RIP seperti berikut

R3#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route
Gateway of last resort is 192.168.2.1 to network 0.0.0.0
R    192.168.10.0/24 [120/1] via 192.168.2.1, 00:00:00, Serial0/0
R    192.168.20.0/24 [120/1] via 192.168.2.1, 00:00:00, Serial0/0
R    192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:00, Serial0/0
C    192.168.2.0/24 is directly connected, Serial0/0
C    192.168.3.0/24 is directly connected, Ethernet1/0
R*   0.0.0.0/0 [120/2] via 192.168.2.1, 00:00:00, Serial0/0
  1. Oktober 5, 2009 pukul 8:39 am

    bisa gak kalo kapan2 saya nanyak tentang hal ini….

  2. rudy
    Oktober 22, 2010 pukul 3:40 am

    mau txak gan,.
    protoki dalam dunia route kan ada 3
    setahu saya RIP ,EIGRP,OSPF,…

    nah,..
    gua bingung gan,…tiga nya to ada g’ di linux or mikrotik
    bales ya gan,..
    thank’s ^_^

    • Oktober 25, 2010 pukul 5:17 am

      RIP dan OSPF ada di linux (software quagga)

      kalo mikrotik saya belum pernah pegang, tapi seharusnya RIP dan OSPF ada di sana, karena keduanya merupakan protokol routing standard

      sedangkan EIGRP merupakan protokol routing proprietary dan cuma bisa jalan di router cisco

  3. Mei 3, 2010 pukul 4:51 am

    not bad

  1. April 20, 2009 pukul 1:18 am

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: