Beranda > @GNS3 Lab, Routing TCP/IP Volume 1 > Konfigurasi RIP: Unicast Update

Konfigurasi RIP: Unicast Update

Masih melanjutkan konfigurasi RIP sebelumnya, kali ini ditambahkan sebuah router dalam ethernet link dimana Andy dan Floyd berada. Kebijakan masih tetap bahwa antara Andy dan Floyd tidak boleh ada pertukaran informasi RIP, tapi kini Bea-Andy, seperti halnya juga Bea-Floyd harus saling mengadvertise RIP update. Perhatikan topologinya berikut ini

1-topology-rip-unicast-upda

Konfigurasi pada Bea sederhana saja seperti berikut ini:

Bea#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Bea(config)#router rip
Bea(config-router)#network 192.168.12.0
Bea(config-router)#network 192.168.200.0
Bea(config-router)#^Z
Bea#

Dengan menggunakan perintah neighbor dibawah proses RIP pada router Andy memungkinkan RIP untuk mengadvertise secara unicast kepada interface Bea, sementara perintah passive-interface tetap digunakan untuk mencegah update secara broadcast pada data link.

Andy#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Andy(config)#router rip
Andy(config-router)# passive-interface Ethernet0/0
Andy(config-router)# network 172.17.0.0
Andy(config-router)# network 192.168.12.0
Andy(config-router)# network 192.168.83.0
Andy(config-router)#neighbor 192.168.12.67
Andy#

Karena Floyd kini harus mengadvertise update RIP kepada Bea, maka perintah network untuk 192.168.12.0 harus digunakan. Dengan bantuan perintah passive-interface maka Floyd dapat mencegah RIP mengadvertise update secara broadcast, dan perintah neighbor digunakan untuk memungkinkan RIP meng-advertise secara unicast kepada Bea.

Floyd#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Floyd(config)#router rip
Floyd(config-router)#passive-interface e0/0
Floyd(config-router)#network 192.168.12.0
Floyd(config-router)#network 192.168.100.0
Floyd(config-router)#neighbor 192.168.12.67
Floyd(config-router)#^Z
Floyd#

Dengan meng-enable debug ip rip pada Andy, maka dapat kita lihat yang terjadi pada router Andy dengan konfigurasi baru. Andy menerima update dari Bea, tetapi tidak dari Floyd, dan mengirimkan update kepada Bea, tetapi tidak mem-broadcastnya pada interface e0/0.

Andy#debug ip rip
RIP protocol debugging is on
Andy#
*Mar  1 01:00:15.555: RIP: received v1 update from 192.168.83.224 on Ethernet0/1
*Mar  1 01:00:15.555:      10.0.0.0 in 1 hops
*Mar  1 01:00:19.215: RIP: sending v1 update to 255.255.255.255 via Ethernet0/2 (192.168.12.195)
*Mar  1 01:00:19.215: RIP: build update entries
*Mar  1 01:00:19.215:   network 10.0.0.0 metric 2
*Mar  1 01:00:19.215:   network 172.17.0.0 metric 1
*Mar  1 01:00:19.219:   subnet 192.168.12.64 metric 1
*Mar  1 01:00:19.219:   network 192.168.83.0 metric 1
*Mar  1 01:00:19.219:   network 192.168.200.0 metric 2
*Mar  1 01:00:22.111: RIP: sending v1 update to 192.168.12.67 via Ethernet0/0 (192.168.12.65)
*Mar  1 01:00:22.111: RIP: build update entries
*Mar  1 01:00:22.111:   network 10.0.0.0 metric 2
*Mar  1 01:00:22.115:   network 172.17.0.0 metric 1
*Mar  1 01:00:22.115:   subnet 192.168.12.192 metric 1
*Mar  1 01:00:22.115:   network 192.168.83.0 metric 1
*Mar  1 01:00:23.243: RIP: received v1 update from 172.17.2.2 on Serial1/1
*Mar  1 01:00:23.243:      172.17.4.0 in 1 hops
*Mar  1 01:00:24.403: RIP: received v1 update from 172.17.1.2 on Serial1/0
*Mar  1 01:00:24.403:      172.17.3.0 in 1 hops
*Mar  1 01:00:27.391: RIP: received v1 update from 192.168.12.67 on Ethernet0/0
*Mar  1 01:00:27.391:      192.168.200.0 in 1 hops

Meskipun Bea telah mendapatkan entri-entri router dari Andy dan Floyd, dan membroadcast update pada data link ethernet, tetapi kebijakan tetap terlaksana karena adanya split horizon yang mencegah Bea agar tidak meng-advertise kembali route-route yang dipelajari dari kedua router ke ethernet.

  1. Belum ada komentar.
  1. No trackbacks yet.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: