Beranda > @GNS3 Lab, Routing TCP/IP Volume 1 > Konfigurasi RIP: dasar-dasar

Konfigurasi RIP: dasar-dasar

Hanya diperlukan 2 langkah untuk mengkonfigurasi RIP:

  1. Meng-enable RIP dengan perintah router rip.
  2. Menentukan setiap network major yang akan digunakan untuk menjalankan RIP dengan perintah network. Gambar berikut menunjukkan sebuah network dengan 4 router dengan 4 nomor network major.

1-topology-rip-basic2

Perintah yang diperlukan untuk meng-enable RIP pada router Goober ditampilkan pada contoh berikut

Goober#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Goober(config)#router rip
Goober(config-router)#network 172.17.0.0
Goober(config-router)#^Z
Goober#

Opie juga memiliki 2 subnet dengan network major yang sama dan akan dikonfigurasi seperti berikut:

Opie#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Opie(config)#router rip
Opie(config-router)#network 172.17.0.0
Opie(config-router)#^Z
Opie#

Mengeksekusi perintah router akan membawa router kedalam mode config-router, hal ini diindikasikan oleh prompt pada router. Sifat nature classful dari RIP dan penyembunyian subnet pada network boundaries maksudnya adalah bahwa tidak akan ada subnet yang ditetapkan dengan perintah network. Hanya address network major kelas A,B,atau C. RIP dapat berjalan pada setiap interface yang dikonfigurasi dengan address apapun yang termasuk anggota dari network yang ditetapkan pada perintah network.

Barney terhubung pada 2 network major 10.0.0.0 dan 192.168.83.0. Karena itu, kedua network harus ditentukan seperti pada contoh berikut:

Barney#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Barney(config)#router rip
Barney(config-router)#network 192.168.83.0
Barney(config-router)#network 10.0.0.0
Barney(config-router)#^Z
Barney#

Andy terhubung pada network major 192.168.83.0, dan terhubung pada 2 subnet dari network major 192.168.12.0 dan terhubung pada 2 subnet dari network major 172.17.0.0

Andy#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Andy(config)#router rip
Andy(config-router)#network 172.17.0.0
Andy(config-router)#network 192.168.12.0
Andy(config-router)#network 192.168.83.0
Andy(config-router)#^Z
Andy#

Pada contoh dibawah ini, perintah debug ip rip telah dieksekusi pada router Andy. Hal yang menarik disini adalah penyembunyian subnet yang dilakukan oleh router. Subnet 192.168.12.64 dan 192.168.12.192 di advertise diantara interface e0/0 dan e0/2, yang keduanya berada dibawah major network 192.168.12.0, tetapi subnet-subnet tersebut di summarize saat update dikirim keluar melalui e0/1,s1/0,dan s1/0, yang kesemuanya berada pada network yang berbeda. Begitu juga, network 192.168.83.0 dan 172.17.0.0 di summarize melintasi batasan-batasan classful. Perhatikan juga bahwa Andy menerima summary route untuk network 10.0.0.0 dari Barney. Dan terakhir, split horizon dapat diamati disini. Misalnya, advertisement yang menuju Barney melalui e0/1 tidak berisi network 10.0.0.0 ataupun 192.168.83.0.

*Mar  1 00:26:26.219: RIP: sending v1 update to 255.255.255.255 via Ethernet0/1 (192.168.83.1)
*Mar  1 00:26:26.223: RIP: build update entries
*Mar  1 00:26:26.223:   network 172.17.0.0 metric 1
*Mar  1 00:26:26.227:   network 192.168.12.0 metric 1
*Mar  1 00:26:30.171: RIP: received v1 update from 172.17.2.2 on Serial1/1
*Mar  1 00:26:30.175:      172.17.4.0 in 1 hops
*Mar  1 00:26:36.211: RIP: received v1 update from 172.17.1.2 on Serial1/0
*Mar  1 00:26:36.215:      172.17.3.0 in 1 hops
*Mar  1 00:26:38.887: RIP: sending v1 update to 255.255.255.255 via Ethernet0/2 (192.168.12.195)
*Mar  1 00:26:38.891: RIP: build update entries
*Mar  1 00:26:38.891:   network 10.0.0.0 metric 2
*Mar  1 00:26:38.895:   network 172.17.0.0 metric 1
*Mar  1 00:26:38.895:   subnet 192.168.12.64 metric 1
*Mar  1 00:26:38.899:   network 192.168.83.0 metric 1
*Mar  1 00:26:39.899: RIP: sending v1 update to 255.255.255.255 via Serial1/0 (172.17.1.1)
*Mar  1 00:26:39.903: RIP: build update entries
*Mar  1 00:26:39.903:   network 10.0.0.0 metric 2
*Mar  1 00:26:39.907:   subnet 172.17.2.0 metric 1
*Mar  1 00:26:39.907:   subnet 172.17.4.0 metric 2
*Mar  1 00:26:39.911:   network 192.168.12.0 metric 1
*Mar  1 00:26:39.911:   network 192.168.83.0 metric 1
*Mar  1 00:26:40.123: RIP: received v1 update from 192.168.83.244 on Ethernet0/1
*Mar  1 00:26:40.127:      10.0.0.0 in 1 hops
*Mar  1 00:26:44.543: RIP: sending v1 update to 255.255.255.255 via Ethernet0/0 (192.168.12.65)
*Mar  1 00:26:44.547: RIP: build update entries
*Mar  1 00:26:44.547:   network 10.0.0.0 metric 2
*Mar  1 00:26:44.551:   network 172.17.0.0 metric 1
*Mar  1 00:26:44.551:   subnet 192.168.12.192 metric 1
*Mar  1 00:26:44.555:   network 192.168.83.0 metric 1
*Mar  1 00:26:45.315: RIP: sending v1 update to 255.255.255.255 via Serial1/1 (172.17.2.1)
*Mar  1 00:26:45.315: RIP: build update entries
*Mar  1 00:26:45.315:   network 10.0.0.0 metric 2
*Mar  1 00:26:45.315:   subnet 172.17.1.0 metric 1
*Mar  1 00:26:45.315:   subnet 172.17.3.0 metric 2
*Mar  1 00:26:45.315:   network 192.168.12.0 metric 1
*Mar  1 00:26:45.315:   network 192.168.83.0 metric 1
  1. Belum ada komentar.
  1. No trackbacks yet.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: