Beranda > @GNS3 Lab, Routing First Step > RIPv2 -part1-

RIPv2 -part1-

RIP versi 2, atau RIPv2, masih memiliki hampir semua keterbatasan-keterbatasan yang ada pada RIPv1. Metric, convergence time, jangkauan network, dan counting to infinity masih ada pada RIPv2. Perbedaan antara keduanya adalah pada RIPv2, sudah ada dukungan terhadap VLSM. Update routing pada RIPv2 kini juga berisi informasi subnet mask. Kali ini akan digunakan topologi seperti pada RIPv1 tapi dengan sedikit perubahan, perhatikan gambar topologi berikut

ripv2-topology

Konfigurasi Awal

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#int s1/0
A(config-if)#ip addr 172.16.4.1 255.255.255.252
A(config-if)#no shut
A(config-if)#int e2/0
A(config-if)#ip addr 172.16.0.5 255.255.255.240
A(config-if)#no shut
A(config)#int e2/1
A(config-if)#ip addr 172.16.1.5 255.255.255.192
A(config-if)#no shut
A(config-if)#^Z
A#

B#conf t
Enter configuration commands, one per line. End with CNTL/Z.
B(config)#int s1/0
B(config-if)#ip addr 172.16.4.2 255.255.255.252
B(config-if)#no shut
B(config-if)#int e2/0
B(config-if)#ip addr 172.16.2.5 255.255.255.224
B(config-if)#no shut
B(config-if)#int e2/1
B(config-if)#ip addr 172.16.3.5 255.255.255.128
B(config-if)#no shut
B(config-if)#^Z
B#

Konfigurasi RIPv2

A#
A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#router rip
A(config-router)#version 2
A(config-router)#passi
A(config-router)#passive-interface eth2/0
A(config-router)#passive-interface eth2/1
A(config-router)#network 172.16.0.0
A(config-router)#^Z
A#

B#conf t
Enter configuration commands, one per line. End with CNTL/Z.
B(config)#router rip
B(config-router)#version 2
B(config-router)#pass
B(config-router)#passive-interface eth2/0
B(config-router)#passive-interface eth2/1
B(config-router)#network 172.16.0.0
B(config-router)#^Z
B#

Output debug pada Router B akan menunjukkan bahwa informasi subnet mask akan di transmisikan pada proses RIPv2, perhatikan contoh berikut (bandingkan ketika debug pada RIPv1)

B#debug ip rip
RIP protocol debugging is on
B#
*Mar 1 00:14:11.611: RIP: sending v2 update to 224.0.0.9 via Serial1/0 (172.16.4.2)
*Mar 1 00:14:11.611: RIP: build update entries
*Mar 1 00:14:11.611: 172.16.2.0/27 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:14:11.615: 172.16.3.0/25 via 0.0.0.0, metric 1, tag 0
B#
*Mar 1 00:14:12.923: RIP: received v2 update from 172.16.4.1 on Serial1/0
*Mar 1 00:14:12.923: 172.16.0.0/28 via 0.0.0.0 in 1 hops
*Mar 1 00:14:12.927: 172.16.1.0/26 via 0.0.0.0 in 1 hops

Semua routing dari RIP akan tampak pada tabel routing walaupun menggunakan subnet mask yang berbeda-beda

A#sh ip route
172.16.0.0/16 is variably subnetted, 5 subnets, 5 masks
C 172.16.4.0/30 is directly connected, Serial1/0
C 172.16.0.0/28 is directly connected, Ethernet2/0
C 172.16.1.0/26 is directly connected, Ethernet2/1
R 172.16.2.0/27 [120/1] via 172.16.4.2, 00:00:23, Serial1/0
R 172.16.3.0/25 [120/1] via 172.16.4.2, 00:00:23, Serial1/0

RIPv2 termasuk protokol routing classless, dan RIPv2 termasuk protokol classful, classless berarti protokol mendukung penggunaan VLSM, sedangkan classful berarti diasumsikan bahwa subnet mask diasosiasikan dengan prefix network karena informasi subnet mask tidak ikut disertakan dalam proses update routing.

Peningkatan lainnya dalam RIPv2 adalah update routing dikirimkan pada address multicast 224.0.0.9, bukan address broadcast 255.255.255.255:

*Mar 1 00:14:11.611: RIP: sending v2 update to 224.0.0.9 via Serial1/0 (172.16.4.2)

2-multicast

Jika router-router terhubung pada satu network multi-access, biasanya sebuah ethernet, maka semua host pada network akan menerima update broadcast, meski tidak ditujukan pada mereka, kemudian me-reject update tersebut. Update multicast hanya dikirimkan kepada host atau router yang ingin menerima traffik update yang dikirimkan ke address multicast. Hal ini mengurangi traffik yang dikirimkan ke host.

Security

RIPv2 punya kemampuan untuk mengautentikasi proses update routing. Orang lain bisa saja memalsukan update RIP dengan menggunakan program-program yang mengirimkan update routing palsu. Metode pertama adalah dengan simple password, menggunakan password tidak ter-enkripsi yang disertakan dalam update routing.Password yang tidak ter-enkripsi dapat dibaca dengan memeriksa paket data yang lewat. Metode kedua adalah dengan message digest, menggunakan password yang sudah ter-enkripsi. Jika seseorang dapat meng-capture dan memeriksa isi paket, password tetap tidak dapat terbaca.Kedua metode ini harus menggunakan password yang sama pada router-router yang saling bertukar informasi routing. Perhatikan contoh berikut :

B#conf t
Enter configuration commands, one per line. End with CNTL/Z.
B(config)#key chain angel
B(config-keychain)#key 1
B(config-keychain-key)#key-string wing
B(config-keychain-key)#int s1/0
B(config-if)#ip addr 172.16.4.1 255.255.255.252
B(config-if)#ip rip authentication key-chain angel
B(config-if)#^Z
B#

Autentikasi dengan menggunakan key chain angel dan password wing di enable pada interface serial di Router B tapi tidak di Router A. Kini Router B akan menolak semua update RIP yang diterima dari Router A

B#debug ip rip
RIP protocol debugging is on
B#
*Mar 1 00:39:56.215: RIP: ignored v2 packet from 172.16.4.1 (sourced from one of our addresses)
B#

Konfigur Router A agar menggunakan password yang sama dengan Router B.

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#key chain angel2
A(config-keychain)#key 1
A(config-keychain-key)#key-string wing
A(config-keychain-key)#int s1/0
A(config-if)#ip addr 172.16.4.1 255.255.255.252
A(config-if)#ip rip authentication key-chain angel2
A(config-if)#^Z
A#

Router A dikonfigurasi menggunakan key chain angel2 dan Router B menggunakan key chain angel. Key chain mendefinisikan password yang akan digunakan oleh RIP. Kita dapat mendefinisikan banyak key chain, dan memilih salah satu untuk digunakan pada Router A dan B. nama key chain tidak perlu sama pada kedua router, hanya password yang digunakan dalam key chains yang harus sesuai keduanya.
Password dikirimkan dalam bentuk clear text, dan seseorang bisa saja menginterupsi jalannya sebuah paket update routing dan melihat password yang dipakai. Authentikasi yang lebih aman adalah dengan menggunakan message digest 5 (MD5). Dengan MD5, password akan di enkripsi terlebih dahulu sebelum dikirimkan. Kalaupun ada seseorang yang menginterupsi paket yang lewat, dia tidak akan bisa membaca password yang dipakai. Untuk meng-enable authentikasi dengan MD5, lakukan konfigurasi pada interface serial pada kedua Router.

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#int s1/0
A(config-if)#ip rip auth
A(config-if)#ip rip authentication mode md5
A(config-if)#^Z
A#

B#conf t
Enter configuration commands, one per line. End with CNTL/Z.
B(config)#int s1/0
B(config-if)#ip rip auth
B(config-if)#ip rip authentication mode md5
B(config-if)#^Z
B#

Kini password yang dikirim akan terenkripsi, perhatikan contoh hasil debug ip rip berikut :

A#debug ip rip
RIP protocol debugging is on
A#
*Mar 1 00:59:24.567: RIP: received packet with MD5 authentication
*Mar 1 00:59:24.567: RIP: received v2 update from 172.16.4.2 on Serial1/0
*Mar 1 00:59:24.567: 172.16.2.0/27 via 0.0.0.0 in 1 hops
*Mar 1 00:59:24.571: 172.16.3.0/25 via 0.0.0.0 in 1 hops
A#

  1. Belum ada komentar.
  1. April 6, 2009 pukul 1:39 pm

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: