Beranda > @GNS3 Lab, Routing First Step > RIPv1 -part2-

RIPv1 -part2-

Topologi dan Kondisi Awal

topology

Router A

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#int fa0/0
A(config-if)#ip addr 172.16.0.5 255.255.255.0
A(config-if)#no shut
A(config-if)#int fa0/1
A(config-if)#ip addr 172.16.1.5 255.255.255.0
A(config-if)#no shut
A(config-if)#int s1/0
A(config-if)#ip addr 172.16.4.1 255.255.255.0
A(config-if)#no shut
A(config-if)#^Z
A#

A#
A#sh ip route
172.16.0.0/24 is subnetted, 3 subnets
C 172.16.4.0 is directly connected, Serial1/0
C 172.16.0.0 is directly connected, FastEthernet0/0
C 172.16.1.0 is directly connected, FastEthernet0/1
A#

Router B

B#conf t
Enter configuration commands, one per line. End with CNTL/Z.
B(config)#int s1/0
B(config-if)#ip addr 172.1
B(config-if)#ip addr 172.16.4.2 255.255.255.0
B(config-if)#no shut
B(config-if)#int fa0/0
B(config-if)#ip addr 172.16.2.5 255.255.255.0
B(config-if)#no shut
B(config-if)#int fa0/1
B(config-if)#ip addr 172.16.3.5 255.255.255.0
B(config-if)#no shut
B(config-if)#int s1/1
B(config-if)#ip addr 172.16.5.1 255.255.255.0
B(config-if)#no shut
B(config-if)#^Z
B#

B#sh ip route
172.16.0.0/24 is subnetted, 4 subnets
C 172.16.4.0 is directly connected, Serial1/0
C 172.16.5.0 is directly connected, Serial1/1
C 172.16.2.0 is directly connected, FastEthernet0/0
C 172.16.3.0 is directly connected, FastEthernet0/1

Router C

C#
C#conf t
Enter configuration commands, one per line. End with CNTL/Z.
C(config)#int s1/0
C(config-if)#ip addr 172.16.5.2 255.255.255.0
C(config-if)#no shut
C(config-if)#int fa0/0
C(config-if)#ip addr 172.16.6.5 255.255.255.0
C(config-if)#no shut
C(config-if)#int fa0/1
C(config-if)#ip addr 172.16.7.5 255.255.255.0
C(config-if)#no shut
C(config-if)#int s1/1
C(config-if)#ip addr 172.16.10.1 255.255.255.0
C(config-if)#no shut
C(config-if)#^Z

C#sh ip route
172.16.0.0/24 is subnetted, 4 subnets
C 172.16.10.0 is directly connected, Serial1/1
C 172.16.5.0 is directly connected, Serial1/0
C 172.16.6.0 is directly connected, FastEthernet0/0
C 172.16.7.0 is directly connected, FastEthernet0/1

Router D

D#conf t
Enter configuration commands, one per line. End with CNTL/Z.
D(config)#int s1/0
D(config-if)#ip addr 172.16.10.2 255.255.255.0
D(config-if)#no shut
D(config-if)#int fa0/0
D(config-if)#ip addr 172.16.9.5 255.255.255.0
D(config-if)#no shut
D(config-if)#int fa0/1
D(config-if)#ip addr 172.16.8.5 255.255.255.0
D(config-if)#no shut
D(config-if)#^Z
D#

D#sh ip route
172.16.0.0/24 is subnetted, 3 subnets
C 172.16.8.0 is directly connected, FastEthernet0/1
C 172.16.9.0 is directly connected, FastEthernet0/0
C 172.16.10.0 is directly connected, Serial1/0

Konfigurasi RIP versi 1 dan Teori

Penjelasan ada pada postingan sebelumnya 😀
Router A

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#router rip
A(config-router)#passive-interface fa0/0
A(config-router)#passive-interface fa0/1
A(config-router)#network 172.16.0.0
A(config-router)#^Z
A#

Router B

B#conf t
Enter configuration commands, one per line. End with CNTL/Z.
B(config)#router rip
B(config-router)#passive-interface fa0/0
B(config-router)#passive-interface fa0/1
B(config-router)#network 172.16.0.0
B(config-router)#^Z
B#

Router C

C#conf t
Enter configuration commands, one per line. End with CNTL/Z.
C(config)#router rip
C(config-router)#version 1
C(config-router)#passive-interface fa0/0
C(config-router)#passive-interface fa0/1
C(config-router)#network 172.16.0.0
C(config-router)#^Z
C#

Router D

D#conf t
Enter configuration commands, one per line. End with CNTL/Z.
D(config)#router rip
D(config-router)#version 1
D(config-router)#passive-interface fa0/0
D(config-router)#passive-interface fa0/1
D(config-router)#network 172.16.0.0
D(config-router)#^Z
D#s

D#show ip route
172.16.0.0/24 is subnetted, 11 subnets
C 172.16.8.0 is directly connected, FastEthernet0/1
C 172.16.9.0 is directly connected, FastEthernet0/0
C 172.16.10.0 is directly connected, Serial1/0
R 172.16.4.0 [120/2] via 172.16.10.1, 00:00:08, Serial1/0
R 172.16.5.0 [120/1] via 172.16.10.1, 00:00:08, Serial1/0
R 172.16.6.0 [120/1] via 172.16.10.1, 00:00:08, Serial1/0
R 172.16.7.0 [120/1] via 172.16.10.1, 00:00:08, Serial1/0
R 172.16.0.0 [120/3] via 172.16.10.1, 00:00:08, Serial1/0
R 172.16.1.0 [120/3] via 172.16.10.1, 00:00:08, Serial1/0
R 172.16.2.0 [120/2] via 172.16.10.1, 00:00:08, Serial1/0
R 172.16.3.0 [120/2] via 172.16.10.1, 00:00:08, Serial1/0

Teddy

root@teddy:~# traceroute -n 172.16.9.200
traceroute to 172.16.9.200 (172.16.9.200), 30 hops max, 38 byte packets
1 172.16.1.5 18.621 ms 35.539 ms 35.910 ms
2 172.16.4.2 58.021 ms 8.377 ms 40.540 ms
3 172.16.5.2 52.091 ms 46.528 ms 78.800 ms
4 172.16.10.2 48.629 ms 39.320 ms 52.327 ms
5 172.16.9.200 60.106 ms 85.700 ms 88.390 ms
root@teddy:~#

Convergence

Properti penting setiap protokol routing adalah waktu yang dibutuhkan agar informasi routing yang tepat dan lengkap dapat disebarkan ke semua router dalam network. Jika terjadi perubahan, baik dengan adanya penambahan network, atau ada salah satu network yang down, atau router yang mengalami kegagalan, informasi baru harus sergera di advertise ke semua router. Waktu yang dibutuhkan agar network mengupdate semua tabel routing-nya dinamakan convergence time.

Teknik yang digunakan untuk mengurangi lama convergence time ini disebut triggered updates. Kapan saja terjadi perubahan tabel routing pada router akan segera dikirimkan update dan router mengirimkan tabel routing dengan segera. Jika interface pada Router A mengalami kegagalan, maka perubahan ini akan disebarkan ke seluruh network menggunakan triggered updates; dan convergence time akan berkurang banyak.

Misalnya saja Router A mati, dan network 172.16.0.0/24 dan 172.16.1.0/24 tak lagi dapat diakses. Router A juga tidak dapat mengirimkan triggered update (karena mati). Bagaimana router-router yang lain mengetahui bahwa network-network tersebut tidak dapat dicapai? Untuk setiap rute yang diterima melalui proses RIP, sebuah update time akan diasosiasikan dengan rute tersebut. Misalnya, nilai update timer untuk network 172.16.1.0 pada Router B dapat ditunjukkan melalu tabel routing berikut :

R       172.16.1.0 [120/1] via 172.16.4.1, 00:00:13, Serial0

Rute ini diterima 13 detik yang lalu. Update timer bertambah setiap detik dan di reset ke 0 setiap ada update baru dari Router A. Jika Router A gagal, update timer akan terus meningkat. Ketika update timer mencapai 180 detik, rute akan dianggap tidak bisa dicapai (hop count > 15). Prefix akan di advertise dengan hop count 4,294,967,295 (angka terbesar 32-bit number), yang menunjukkan bahwa rute tidak valid. Ketika update timer berakhir, 2 timer akan ditambahkan : holddown and flush timers.

Misalkan jika serial interface Router A gagal. Router A dapat lagi mengirim update tabel routing pada Router B. Timer pada Router B untuk prefix yang didapat dari Router A akan terus bertambah, seperti berikut :
Router B

B#sh ip rip database
172.16.0.0/16 auto-summary
172.16.0.0/24
[1] via 172.16.4.1, 00:00:44, Serial1/0
172.16.1.0/24
[1] via 172.16.4.1, 00:00:44, Serial1/0

B#sh ip rip database
172.16.0.0/16 auto-summary
172.16.0.0/24 is possibly down
172.16.1.0/24 is possibly down

Variable-Length Subnet Masks

Variable-length subnet masks (VLSMs), berarti bahwa panjang subnet mask yang berbeda-beda digunakan dalam satu network. Pada contoh sebelumnya semua subnet menggunakan subnet mask 24-bit.  Ini berarti setiap network dapat menampung 254 host. Koneksi point-to-point hanya dapat menampung 2 hosts. Jika digunakan 24-bit mask pada koneksi point-to-point, 2 dari 254 address dipakai, dan sisanya 252 host tidak dapat dipakai. Kita ubah sedikit topologi diatas menjadi seperti ini

topology2

Dengan menggunakan mask 30-bit sebagai ganti 24-bit, berarti ada 252 host yang dapat terselamatkan dari ke-mubazir-an😀 konfigurasi baru pada interface serial Router A dan B dapat ilihat pada contoh berikut.
Router A

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#int s1/0
A(config-if)#ip addr 172.16.4.1 255.255.255.252
A(config-if)#^Z
A#


Router B

B#conf t
Enter configuration commands, one per line. End with CNTL/Z.
B(config)#int s1/0
B(config-if)#ip addr 172.16.4.2 255.255.255.252
B(config-if)#^Z
B#

Jika kita lihat tabel routing setelah konfigurasi diatas, akan nampak sebagai berikut :
Router A

A#sh ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.16.4.0/30 is directly connected, Serial1/0
C 172.16.0.0/24 is directly connected, FastEthernet0/0
C 172.16.1.0/24 is directly connected, FastEthernet0/1
A#

Router B

B#sh ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.16.4.0/30 is directly connected, Serial1/0
C 172.16.2.0/24 is directly connected, FastEthernet0/0
C 172.16.3.0/24 is directly connected, FastEthernet0/1
B#

Tabel routing menunjukkan ada 2 mask yang digunakan : /24 dan /30. Harus kita perhatikan bahwa tidak ada rute yang berasal dari RIPv1 pada kedua tabel. Ini menunjukkan keterbatasan lain dari RIPv1. Keterbatasan itu adalah bahwa informasi subnet mask tidak disertakan pada update routing. Jadi bagaimana router dapat mengetahui subnet mana yang akan digunakan? Jika prefix network, seperti 172.16.1.0, diterima pada interface yang dikonfigurasi dengan IP address dari nomor major network yang sama, maka akan diasumsikan mask dari prefix yang diterima menggunakan mask yang sama pada interface yang menerima.

Sebagai permisalan, prefix network kelas B 172.16.0.0/16 adalah nomor major network untuk semua subnet 172.16.0.0. Prefix network kelas A 12.0.0.0/8 adalah nomor major network untuk semua subnet dari 12.0.0.0/8, dan 193.1.2.0/24 adalah nomor major network untuk semua subnet 193.1.2.0/24. Network pada topologi diatas hanya menggunakan subnet dengan nomor major network 172.16.0.0/16.

RIP mengasumsikan bahwa prefix-prefix yang diterima pada interface serial yang berada pada major network 172.16.0.0 akan menggunakan mask 30-bit. Router pengirim hanya mengadvertise rute dengan mask 30-bit melalu interface serial. Informasi network dibalik router yang menggunakan mask 24-bit tidak akan pernah dikirimkan kepada Router B.

Untuk membuktikan hal ini, kita coba mengganti subnet mask pada interface FastEthernet Router A menjadi 30-bit, seperti pada contoh berikut
Router A

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#int fa0/0
A(config-if)#ip addr 172.16.0.5 255.255.255.252
A(config-if)#int fa0/1
A(config-if)#ip addr 172.16.1.5 255.255.255.252
A(config-if)#^Z
A#

Network ini akan berada pada tabel routing Router B.
Router B

B#sh ip route
172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
C 172.16.4.0/30 is directly connected, Serial1/0
R 172.16.0.4/30 [120/1] via 172.16.4.1, 00:00:00, Serial1/0
R 172.16.1.4/30 [120/1] via 172.16.4.1, 00:00:00, Serial1/0
C 172.16.2.0/24 is directly connected, FastEthernet0/0
C 172.16.3.0/24 is directly connected, FastEthernet0/1
B#

Kini network FastEthernet pada Router A hanya dapat menampung 2 host, dan salah satunya digunakan oleh router. Sekarang bagaimana kalau kita mengganti IP address dari interface FastEthernet1 pada Router A menggunakan address yang berbeda dari prefix major network. Seperti berikut :


Router A

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#int fa0/1
A(config-if)#ip addr 156.26.1.5 255.255.255.0
A(config-if)#router rip
A(config-router)#network 172.16.0.0
A(config-router)#network 156.26.0.0
A(config-router)#^Z
A#

Router B

B#sh ip route
R 156.26.0.0/16 [120/1] via 172.16.4.1, 00:00:13, Serial1/0
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.4.0/30 is directly connected, Serial1/0
R 172.16.0.4/30 [120/1] via 172.16.4.1, 00:00:13, Serial1/0
C 172.16.2.0/24 is directly connected, FastEthernet0/0
C 172.16.3.0/24 is directly connected, FastEthernet0/1
B#

2 hal yang perlu diperhatikan :

  • Network 156.26.0.0 telah diadvertise pada Router B
  • Subnet mask yang dipakai adalah /16, bukan /24 seperti yang telah dikonfigurasikan pada Router A.

Karena prefix 156.26.1.0 berada pada nomor major network yang berbeda dari interface yang menghubungkan antar-router, Router A otomatis meringkas (summarizes) advertisement menjadi classfull. Standard mask untuk kelas B adalah 16-bit, dan mask ini diasumsikan dipakai oleh network 156.26.0.0. Hal ini membawa masalah lain. Router B kini beranggapan bahwa dia bisa mencapai semua address kelas B 156.26.0.0/16 melalui Router A. Tetapi Router A hanya menggunakan satu subnet saja dari 156.26.0.0.

Hop Count Limitation

Bandwidth pada interface adalah angka bits per second (bps) yang dapat ditransmisikan. Tabel berikut menunjukkan list beberapa bandwidth, pada satuan millions bits per second (Mbps) dari bermacam jenis interface router.

Interface Type Bandwidth (Mbps)
Ethernet 10
Fast Ethernet 100
Gigabit Ethernet 1000
T1 1.544
E1 2.048

1-bandwidth1

Jika RIP digunakan pada network diatas, maka jalur terbaik dari Router A menuju network 1 adalah melalui koneksi T1 menuju Router C karena hop count nya sebesar 1. Jalur dari Router B menuju network 1 memiliki hop count sebesar 2; tetapi bandwidth dari A-B-C lebih besar dari pada bandwidth A-C. RIP tidak mempertimbangkan bandwidth saat menentukan jalur terbaik, hanya hop count yang dipakai. Ini adalah keterbatasan lain dari RIP.

  1. Belum ada komentar.
  1. No trackbacks yet.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: