Beranda > @GNS3 Lab, Routing First Step > RIPv1 -part1-

RIPv1 -part1-

Konfigurasi Awal dan Topologi

topology-rip-v11


Router A

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#int fa0/0
A(config-if)#ip addr 172.16.0.5 255.255.255.0
A(config-if)#no shut
A(config-if)#int fa0/1
A(config-if)#ip addr 172.16.1.5 255.255.255.0
A(config-if)#no shut
A(config-if)#int s1/0
A(config-if)#ip addr 172.16.4.1 255.255.255.0
A(config-if)#no shut
A(config-if)#^Z
A#

A#sh ip route
172.16.0.0/24 is subnetted, 3 subnets
C 172.16.4.0 is directly connected, Serial1/0
C 172.16.0.0 is directly connected, FastEthernet0/0
C 172.16.1.0 is directly connected, FastEthernet0/1

Router B

B#conf t
Enter configuration commands, one per line. End with CNTL/Z.
B(config)#int fa0/0
B(config-if)#ip addr 172.16.2.5 255.255.255.0
B(config-if)#no shut
B(config-if)#int fa0/1
B(config-if)#ip addr 172.16.3.5 255.255.255.0
B(config-if)#no shut
B(config-if)#int s1/0
B(config-if)#ip addr 172.16.4.2 255.255.255.0
B(config-if)#no shut
B(config-if)#^Z
B#

B#sh ip route
172.16.0.0/24 is subnetted, 3 subnets
C 172.16.4.0 is directly connected, Serial1/0
C 172.16.2.0 is directly connected, FastEthernet0/0
C 172.16.3.0 is directly connected, FastEthernet0/1

Konfigurasi RIPv1 dan Teori

Konfigurasi RIPv1 pada Router A dan Router B

Router A

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#router rip
A(config-router)#version 1
A(config-router)#network 172.16.0.0
A(config-router)#^Z
A#

Router B

B#conf t
Enter configuration commands, one per line. End with CNTL/Z.
B(config)#router rip
B(config-router)#version 1
B(config-router)#network 172.16.0.0
B(config-router)#^Z
B#

teddy

root@teddy:~# traceroute -n 172.16.2.200
traceroute to 172.16.2.200 (172.16.2.200), 30 hops max, 38 byte packets
1 172.16.1.5 25.619 ms 4.886 ms 2.442 ms
2 172.16.4.2 26.015 ms 11.336 ms 70.977 ms
3 172.16.2.200 48.547 ms 46.029 ms 75.819 ms

Perintah router rip meng-enable proses routing RIP. Dengan perintah version 1 maka versi RIP yang akan dijalankan adalah yang versi 1. network 172.16.0.0 menginstruksikan router untuk mengaktifkan proses routing RIP pada setiap interface yang dikonfigurasi dengan IP address berada pada address block 172.16.0.0/16. Semua interface pada kedua router telah diberikan IP address pada block ini; jadi semua interface ikut berpartisipasi pada proses RIP. Perhatikan bahwa subnet mask tidak digunakan dalam perintah network. RIPv1 dikenal sebagai protokol routing classfull; karena itu router mengasumsikan subnet mask yang digunakan adalah 16-bit karena 172.16.0.0 berasal dari kelas B dan standard mask untuk kelas B adalah 16-bit. Saat proses RIP di enable, router akan meng-advertise semua isi tabel routingnya keluar melalui semua interface yang ikut berpartisipasi pada proses RIPv1 tadi. Hal ini dapat dilihat dengan mengenable fitur debugging pada salah satu router (lihat konfigurasi dibawah). Debugging biasanya digunakan untuk mencari problem-problem yang terjadi pada operasi atau pada konfigurasi router. Debugging juga dapat digunakan untuk melihat apa saja sebenarnya yang sedang dilakukan oleh router, walaupun tidak ada problem yang muncul. Debugging adalah fitur yang sangat berguna untuk mem-verifikasi operasi yang tepat, atau untuk menambah pengetahuan kita dalam hal operasi-operasi protokol.

Output Debug RIPv1 pada Router A

Router A

A#debug ip rip
RIP protocol debugging is on
A#
*Mar 1 00:16:42.659: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (172.16.0.5)
*Mar 1 00:16:42.659: RIP: build update entries
*Mar 1 00:16:42.659: subnet 172.16.1.0 metric 1
*Mar 1 00:16:42.659: subnet 172.16.2.0 metric 2
*Mar 1 00:16:42.663: subnet 172.16.3.0 metric 2
*Mar 1 00:16:42.663: subnet 172.16.4.0 metric 1
*Mar 1 00:16:43.111: RIP: received v1 update from 172.16.4.2 on Serial1/0
*Mar 1 00:16:43.111: 172.16.2.0 in 1 hops
*Mar 1 00:16:43.111: 172.16.3.0 in 1 hops
*Mar 1 00:16:43.579: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/1 (172.16.1.5)
*Mar 1 00:16:43.579: RIP: build update entries
A#
*Mar 1 00:16:43.579: subnet 172.16.0.0 metric 1
*Mar 1 00:16:43.579: subnet 172.16.2.0 metric 2
*Mar 1 00:16:43.579: subnet 172.16.3.0 metric 2
*Mar 1 00:16:43.579: subnet 172.16.4.0 metric 1
A#
*Mar 1 00:16:44.687: RIP: sending v1 update to 255.255.255.255 via Serial1/0 (172.16.4.1)
*Mar 1 00:16:44.687: RIP: build update entries
*Mar 1 00:16:44.687: subnet 172.16.0.0 metric 1
*Mar 1 00:16:44.687: subnet 172.16.1.0 metric 1

RIP mengirimkan update routing pada interface FastEthernet (interface yang terhubung ke network klien) karena router tidak tahu bahwa disana tidak ada router lain yang terhubung pada network. Protokol routing mengkomunikasikan prefix network antar router, bukan antara router dan host. Jika tidak ada router lain dalam network, proses RIP dapat di disable pada interface yang terhubung ke network tersebut menggunakan perintah passive-interface dibawah proses routing RIP. Lihat contoh dibawah. Mengkonfigurasi suatu interface sebagai passive mencegah RIP mengadvertise tabel routing ke interface tersebut, tetapi prefix network yang diberikan pada interface tersebut tetap di advertise oleh RIP ke interface-interface non-passive.

Using the passive-interface Command

Router A

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#router rip
A(config-router)#version 1
A(config-router)#passive-interface fa0/0
A(config-router)#passive-interface fa0/1
A(config-router)#network 172.16.0.0
A(config-router)#^Z
A#

Router B

B#conf t
Enter configuration commands, one per line. End with CNTL/Z.
B(config)#router rip
B(config-router)#version 1
B(config-router)#passive-interface fa0/0
B(config-router)#passive-interface fa0/1
B(config-router)#network 172.16.0.0
B(config-router)#^Z
B#

Output Debugging Output dengan Passive-Interfaces pada Router A

Router A

A#debug ip rip
RIP protocol debugging is on
A#
*Mar 1 00:27:16.623: RIP: received v1 update from 172.16.4.2 on Serial1/0
*Mar 1 00:27:16.623: 172.16.2.0 in 1 hops
*Mar 1 00:27:16.627: 172.16.3.0 in 1 hops
A#
*Mar 1 00:27:22.935: RIP: sending v1 update to 255.255.255.255 via Serial1/0 (172.16.4.1)
*Mar 1 00:27:22.935: RIP: build update entries
*Mar 1 00:27:22.935: subnet 172.16.0.0 metric 1
*Mar 1 00:27:22.935: subnet 172.16.1.0 metric 1
A#

Kini router-router hanya mengadvertise tabel routing pada interface serial. Tabel routing untuk router A dan B kini telah komplit.

Verifikasi Tabel Routing oleh RIP

Router A

A#sh ip route
172.16.0.0/24 is subnetted, 5 subnets
C 172.16.4.0 is directly connected, Serial1/0
C 172.16.0.0 is directly connected, FastEthernet0/0
C 172.16.1.0 is directly connected, FastEthernet0/1
R 172.16.2.0 [120/1] via 172.16.4.2, 00:00:02, Serial1/0
R 172.16.3.0 [120/1] via 172.16.4.2, 00:00:02, Serial1/0
A#

Router B

B#sh ip route
172.16.0.0/24 is subnetted, 5 subnets
C 172.16.4.0 is directly connected, Serial1/0
R 172.16.0.0 [120/1] via 172.16.4.1, 00:00:25, Serial1/0
R 172.16.1.0 [120/1] via 172.16.4.1, 00:00:25, Serial1/0
C 172.16.2.0 is directly connected, FastEthernet0/0
C 172.16.3.0 is directly connected, FastEthernet0/1
B#

Router A kini telah mengetahui dua network yang berada dibelakang Router B. Router B juga sudah mengetahui informasi tentang 2 network yang berada dibelakang Router A. Huruf R pada tabel routing mengindikasikan bahwa rute ini didapatkan dari proses RIP. Angka-angka dalam kurung siku [120/1] adalah administrative distance bagi prefix (120) dan metrik bagi prefik (1). Jika lebih dari satu protokol routing yang di enable pada router, maka mungkin saja router mendapatkan informasi tentang suatu prefix network dari beberapa protokol routing. Misalnya, jika router mengetahui network 172.16.1.0/24 dari RIPv1 dan OSPF, maka route yang manakah yang akan diletakkan pada tabel routing? RIP memiliki administrative distance sebesar 120, dan OSPF sebesar 110. Semakin kecil administrative distance semakin baik, jadi informasi dari OSPF lah yang akan ditaruh pada tabel routing.

Secara ringkas, administrative distance menentukan router terbaik yang akan dipilih ketika suatu informasi rute diperoleh dari lebih dari satu protokol routing. Metric menentukan rute terbaik ketika terdapat banyak rute menuju satu tujuan dengan menggunakan protokol routing yang sama.

Route Type Administrative Distance
Connected 0
Static 1
EBGP 20
EIGRP 90
IGRP 100
OSPF 110
IS-IS 115
RIP 120
IBGP 200

RIP adalah distance-vector routing protocol, dan metric pada RIP menggunakan apa yang disebut sebagai hop count. Hop Count adalah ukuran sejauh mana network. Setiap router yang berada antara sumber (source) dan tujuan (destination) disebut hop. Router B mengadvertise semua network yang terhubung langsung (directly connected) dengan hop count 0.


*Mar 1 00:27:16.623: 172.16.2.0 in 1 hops

Hal ini berarti terdapat satu router antara Router A dan network 172.16.3.0.

Counting to Infinity

RIP menganggap router-router yang berada sejauh 16 hop sebagai router tak terjangkau. Pada gambar dibawah ini kita asumsikan router-router sudah saling bertukar tabel routing menggunakan RIP.

Router A mengadvertise network 1 dengan hop count 0. Kemudian Router B menerima advertisement, dan hop count ditambah 1. Router B meng-advertise network 1 kembali ke Router A dengan hop count 1. Router A menolak advertisement yang dilakukan oleh Router B karena network 1 adalah network yang terhubung langsung dengan Router A. jika network 1 down, Router A menghapusnya dari tabel routing. Kita asumsikan Router B mengirimkan tabel routingnya apda Router A sebelum Router A memberitahu pada Router B bahwa network 1 tidak lagi available. Router A menerima advertisement untuk network 1 dari Router B, karena network 1 belum ada dalam tabel routing Router A. Router A kini menganggap network 1 dapat dicapai melalui Router B. Router A me-readvertise network 1 ke Router B dengan hop count 2. Router B menerimanya karena pada awalnya Router B mempelajari rute tersebut dari Router A. Proses ini terus berjalan dan hop count terus bertambah. Untungnya, nilai tak terbatas RIP adalah 166. Ketika hop count mencapai nilai 16, router akan me-reject rute dan menghapusnya dari tabel routing. Setiap network sejauh 15 hop keatas dianggap sebagai network yang tidak dapat dicapai, batas ini adalah ukuran maximal dari network RIP.
Counting to infinity adalah problem warisan dari distance-vector routing protocols. Ada 2 jalan untuk mencegah terjadinya counting to infinity : split horizon dan poison reverse.

Split Horizon

Split horizon adalah sebuah aturan yang menyatakan bahwa router tidak akan meng-advertise keluar sebuah rute ke sebuah interface dimana rute itu didapatkan, bahasa lainnya, tidak bermanfaat mengirimkan update rute yang sama pada router yang mengirimi kita update tersebut. Baca-baca dari sini, mengatakan bahwa sesungguhnya :

  • Split horizon adalah mekanisme yang digunakan oleh distance vector routing protocols untuk mencegah terjadinya masalah counting to infinity.
  • Pada physical serial interface split horizon defaultnya di disable.
  • Pada serial sub-interface split horizon defaultnya di enable.

Router A

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#int s1/0
A(config-if)#no ip split-horizon
A(config-if)#^Z
A#

A#debug ip rip
RIP protocol debugging is on
A#
*Mar 1 01:22:49.887: RIP: received v1 update from 172.16.4.2 on Serial1/0
*Mar 1 01:22:49.887: 172.16.0.0 in 2 hops
*Mar 1 01:22:49.891: 172.16.1.0 in 2 hops
*Mar 1 01:22:49.891: 172.16.2.0 in 1 hops
*Mar 1 01:22:49.891: 172.16.3.0 in 1 hops
*Mar 1 01:22:49.891: 172.16.4.0 in 1 hops
A#
*Mar 1 01:22:55.275: RIP: sending v1 update to 255.255.255.255 via Serial1/0 (172.16.4.1)
*Mar 1 01:22:55.275: RIP: build update entries
*Mar 1 01:22:55.275: subnet 172.16.0.0 metric 1
*Mar 1 01:22:55.275: subnet 172.16.1.0 metric 1
*Mar 1 01:22:55.279: subnet 172.16.2.0 metric 2
*Mar 1 01:22:55.279: subnet 172.16.3.0 metric 2
*Mar 1 01:22:55.279: subnet 172.16.4.0 metric 1
A#
A#no debug ip rip
RIP protocol debugging is off

Mengembalikan fitur split-horizon.

Router A

A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
A(config)#int s1/0
A(config-if)#ip spli
A(config-if)#ip split-horizon
A(config-if)#^Z
A#s

Poison Reverse

Poison reverse memungkinkan untuk me-readvertise rute keluar interface dimana rute tersebut diterima, tetapi dengan hop count yang di set menjadi 16. Hal ini mencegah router penerima untuk menerima advertise tersebut. Route Cisco menggunakan split horizon pada RIP, tapi tidak poison reverse.

  1. Belum ada komentar.
  1. April 3, 2009 pukul 5:36 pm
  2. April 5, 2009 pukul 9:04 am

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: